Справка по программе G&I Mail Checker

Справка по программе
«Gekus & Igori Mail Checker».

Программа «Gekus & Igori Mail Checker» была разработана Заливочкиным Евгением Владимировичем и Овчаренко Игорем Викторовичем с целью упростить работу с собственными почтовыми ящиками, а также для фильтровки спама. К основным достоинствам программы стоит отнести:

Возможность работы с несколькими почтовыми ящиками одновременно.

Возможность удаления сообщений без загрузки их с сервера, как вручную, так и автоматически

Возможность настройки типа уведомления о поступивших сообщениях.

Возможность гибкой на стройки временных интервалов проверки почты.

Возможность выдавать звуковое уведомление о поступившей почте проигрыванием мелодии на PC Speaker.

Поддержка нескольких языков пользовательского интерфейса.

Программа рассчитана на работу в системах Windows 95/98/NT4.x, а также проверена на совместимость с Windows 2000. Текущая версия программы поддерживает работу только по протоколу POP3, однако в следующих версиях планируется поддержка других почтовых протоколов (IMAP, Hotmail).

Программа удобна в работе как при постоянном соединении с Internet (выделенная линия), так и при использовании Dialup-соединения (телефонная линия). Она занимает минимальное количество ресурсов (память, процессорное время) и поэтому вполне может быть запущена постоянно.

Кроме того, благодаря простому интерфейсу, программу легка в использовании и настройке.

В этой справке содержатся следующие разделы:

Общие сведения

Установка и запуск программы

Настройка программы

Дополнительные возможности программы

Элементы интерфейса

Часто задаваемые вопросы


Общие сведения

G&I Mail Checker запускается «резидентно», т.е. в нормальном состоянии не выводит окна на экран. Доступ к программе осуществляется с помощью значка на панели задач Windows, который может иметь один из следующих видов:

Mail Checker не обнаружил новых писем, или информация обо всех письмах уже получена пользователем.

Имеются свежие письма, информацию о которых стоит посмотреть.

Mail Checker проверяет почту.

Mail Checker временно приостановлен

Если Вы щелкните правой кнопкой мышки по значку, то появится основное меню программы, с помощью которого Вы можете выполнить желаемые действия. Кроме того, если Вы наведете курсор мышки на значок и задержите его там на некоторое время, появится всплывающая подсказка с информацией о текущей почте.

Для проверки почты используются т.н. учетные записи, в которых указывается имя сервера входящей почты, имя пользователя и пароль, а также задаются временные интервалы проверки почты. Почта для всех учетных записей проверяется независимо.

При обнаружении новой почты Mail Checker проверяет письмо на предмет соответствия какому-либо правилу уведомления, и реагирует в соответствии с этими правилами. Подробнее о правилах уведомления см. вкладку «Уведомления» окна «Настройки G&I Mail Checker».


Справка по программе G&I Mail Checker

Учетные записи

Учетная запись является описателем одного почтового ящика

G&I Mail Checker запускается «резидентно», т.е. в нормальном состоянии не выводит окна на экран. Доступ к программе осуществляется с помощью значка на панели задач Windows, который может иметь один из следующих видов:

Mail Checker не обнаружил новых писем, или информация обо всех письмах уже получена пользователем.

Имеются свежие письма, информацию о которых стоит посмотреть.

Mail Checker проверяет почту.

Mail Checker временно приостановлен

Если Вы щелкните правой кнопкой мышки по значку, то появится основное меню программы, с помощью которого Вы можете выполнить желаемые действия. Кроме того, если Вы наведете курсор мышки на значок и задержите его там на некоторое время, появится всплывающая подсказка с информацией о текущей почте.

входящей почты, имя пользователя и пароль, а также задаются временные интервалы проверки почты. Почта для всех учетных записей проверяется независимо.

При обнаружении новой почты Mail Checker проверяет письмо на предмет соответствия какому-либо правилу уведомления, и реагирует в соответствии с этими правилами. Подробнее о правилах уведомления см. вкладку «Уведомления» окна «Настройки G&I Mail Checker».


Основное меню программы

Это меню появляется при щелчке правой кнопкой мышки на значке «G&I Mail Checker». Меню содержит следующие пункты:

Письма... | Показать окно со списком писем
Проверить сейчас |
Все учетные записи | Проверить почту для всех учетных записей
<Учетная запись> | Проверить почту для конкретной учетной записи
Настройки... | Открыть окно «Настройки G&I Mail Checker»
Ошибки... | Показать окно с сообщениями об ошибках
Вызов справки | Показать справку
О программе... | Показать информацию о версии программы и разработчиках
Выключить звук! | Выключить все воспроизводимые в данные момент звуки
"Тихий" режим | Включить/выключить «тихий» режим работы
Приостановить | Приостановить/возобновить работу
Завершить работу | Завершить работу программы


Меню окна со списком писем

Это меню расположено вверху (сразу после заголовка) окна со списком писем, и предоставляет основные команды для работы с этим списком. Меню содержит следующие пункты:

Подменю «Файл» |
Запустить почтовую программу | Запустить программу проверки почты
Напомнить позже | Закрыть окно, не помечая письма, как прочитанные
Проверить сейчас | Инициировать проверку почты для всех учетных записей
Закрыть окно | Закрыть окно со списком писем
Подменю «Правка» |
Заголовок... | Показать заголовок письма
Пометить на удаление | Отметить письмо для последующего удаления
Удалить отмеченные | Удалить все отмеченные для удаления письма
Создать правило по отправителю... | Автоматически создать правило, исходя из отправителя отмеченного письма
Создать правило по теме... | Автоматически создать правило, исходя из темы отмеченного письма
Подменю «?» |
Содержание | Показать содержание справки по программе
О программе... | Показать информацию об авторах


Контекстное меню списка писем

Это меню появляется при щелчке правой кнопкой мышки на списке писем. Меню содержит следующие пункты:

Заголовок... | Показать заголовок письма
Пометить на удаление | Отметить письмо для последующего удаления
Удалить отмеченные | Удалить все отмеченные для удаления письма
Создать правило по отправителю... | Автоматически создать правило, исходя из отправителя отмеченного письма
Создать правило по теме... | Автоматически создать правило, исходя из темы отмеченного письма


Контекстное меню списка учетных записей

Это меню появляется при щелчке правой кнопкой мышки на списке учетных записей вкладки «Учетные записи» диалогового окна «Настройки G&I Mail Checker» . Меню содержит следующие пункты::

Свойства... | Запустить программу проверки почты
Добавить... | Запустить программу проверки почты
Удалить | Закрыть окно, не помечая письма, как прочитанные


Диалоговое окно «Настройки G&I Mail Checker»

Это окно позволяет настроить рабочие параметры программы, в том числе учетные записи. Для того, чтобы вывести это окно, выберите пункт меню "Настройки…" из основного меню программы.

Окно содержит три вкладки:

Вкладка «Общие» - позволяет настроить общие параметры системы и задать почтовую программу.

Вкладка «Учетные записи» - позволяет настроить учетные записи для проверки почты и параметры их работы, в том числе временные интервалы.

Вкладка «Уведомления» - позволяет настроить реакцию программы на различные виды писем, а также задать методы звукового оповещения.


Вкладка «Общие» диалогового окна «Настройки G&I Mail Checker»

В этой вкладке настраиваются общие параметры работы Mail Checker. Вкладка содержит следующие поля:

Окно редактирования «Почтовая программа» и кнопка выбора файла служат для выбора файла основной почтовой программы. Эта программа запускается автоматически в случае, если Mail Checker обнаруживает письмо, реакция на которое установлена «Запускать почтовую программу». Если оставить это поле пустым, то почтовая программа запускаться не будет. Подробнее о реакции на сообщения см. вкладку «Уведомления».

Флажок «Не выполнять проверку почты при запущенной почтовой программе» служит для приостановки проверки почты в то время, когда запущена почтовая программа. Обычно большинство почтовых программ сами осуществляют проверку почты, и это может привести к конфликту на сервере или его перегрузку, поэтому, если Ваша почтовая программа сама осуществляет проверку почты, установите этот флажок. Понятно, что если поле «Почтовая программа» оставлено пустым, этот флажок не действует, и почта проверяется всегда.

Следующие флажки имею смысл только если Вы подключены к Internet по Dialup-соединению (по телефонной линии).

Флажок «Подключиться к списку запуска ICQ NetDetect Agent» служит для того, чтобы автоматически запускать программу при подключении к Internet. Mirabilis ICQ (www.mirabilis.com) - очень популярная программа, в состав которой входит т.н. ICQ NetDetect Agent - небольшая программка, которая проверяет наличие соединения. Кроме запуска непосредственно ICQ, она имеет возможность запускать и другие программы, для чего у нее имеется т.н. Lunch List (список запуска). Mail Checker может автоматически прописать самого себя в этот список (конечно, если у Вас установлена ICQ), для чего достаточно установить этот флажок. Если Вы снимете этот флажок, Mail Checker удалит себя из списка запуска. Если этот флажок запрещен, значит, Mail Checker не смог обнаружить ICQ на Вашем компьютере или версия ICQ не совместима с текущей версией Mail Checker.

Флажок «Производить проверку только при установленном Dialup-соединении» служит для блокировки проверки почты при отсутствии Dialup-соединения. Если он установлен, то, прежде чем проверять почту, Mail Checker проверит наличие соединения, и если его не обнаружит, то почта проверяться не будет. Таким образом, не будет выдано сообщение об ошибке «Сервер не найден».

Флажок «Выгружать программу при отсутствии Dialup-соединения» служит для автоматического завершения работы программы в случае, если при попытке проверить почту Mail Checker не находит Dialup-соединения. Подробнее о проблемах, возникающих при работе с этими флажками см. здесь.

Если установить последние три флажка, Mail Checker будет работать практически автономно (при наличии ICQ) - автоматически запускаться и завершаться, что очень удобно при использовании соединения по телефонной линии. При наличии постоянного соединения имеет смысл прописать Mail Checker в папку Startup (Автозагрузка) для автоматического запуска при включении компьютера, т.к. Mail Checker практически не требует ресурсов.

Флажок «Подтверждать завершение работы» служит для того, чтобы Mail Checker запрашивал подтверждение при завершении работы.

Окно редактирования «Хранить сообщения об ошибках не менее, чем … часов» позволяет задать время, в течении которого сообщения об ошибках сохраняются в окне «G&I Mail Checker: Ошибки…». Это бывает удобно для сохранения информации об удаленных письмах. Если указано время 0, то сообщения об ошибках будут удаляться при начале нового сеанса проверки почты.


Вкладка «Учетные записи» диалогового окна «Настройки G&I Mail Checker»

Эта вкладка предназначена для управления учетными записями для проверки почты. Вкладка содержит список учетных записей и панель инструментов для работы с ними. В этой вкладке Вы можете выполнить следующие операции с учетными записями:

Добавить новую учетную запись (клавиша <Insert> на клавиатуре или кнопка [image] на панели инструментов). При этом откроется окно добавления новой учетной записи.

Удалить учетную запись (клавиша <Delete> на клавиатуре или кнопка [image] на панели инструментов). Перед удалением Mail Checker запросит подтверждение выполнения операции.

Редактировать свойства учетной записи (клавиша <Enter> на клавиатуре, кнопка [image] на панели инструментов или двойной щелчок мыши по учетной записи). При этом откроется окно свойств учетной записи.

Все изменения, которые вносятся в список учетных записей, не будут запомнены до тех пор, пока Вы не покинули эту вкладку. Таким образом, если Вы случайно внесли неверные изменения (например, удалили учетную запись), то Вам достаточно нажать кнопку «Отмена» (или <Esc> на клавиатуре), и изменения будут отменены.

Вы можете также вносить изменения в список учетных записей, даже если в этот момент происходит проверка почты. Изменения будут внесены, как только соответствующая учетная запись завершит проверку почты.


Вкладка «Уведомления» диалогового окна «Настройки G&I Mail Checker»

В этой вкладке Вы можете настроить реакцию Mail Checker на различные письма в зависимости от отправителя или темы письма.

В выпадающем списке «Для всех остальных сообщений:» указывается реакция на письма, не попавшие не под одно из специальных правил. Возможны следующие варианты реакции на сообщения:

«Не реагировать на сообщение» - Mail Checker никак внешне не реагирует на поступление письма, и письмо сразу помечается как прочитанное. Под «прочитанным» подразумевается письмо, на которое не надо реагировать в дальнейшем. Никаким образом на сервере оно не отмечается.

«Мигать иконкой на панели задач» - Значок Mail Checker, находящийся на панели задач, начинает мигать ( [image]) до тех пор, пока в списке полученных сообщений останется хоть одно непрочитанное сообщение. Кстати, значок мигает на панели задач при наличии любого непрочитанного сообщения, даже если на него предусмотрена специальная реакция.

«Выводить всплывающее окно» - в правом нижнем углу экрана появляется окошко, аналогичное показанному на рисунке справа, и информацией об общем количестве сообщений и количестве непрочитанных. Окошко появляется поверх всех остальных окон и держится на экране 10 сек.

«Выводить окно с сообщениями» - на экран выводится окно «Список писем» с информацией обо всех полученных сообщениях.

«Запускать почтовую программу» - Mail Checker запускает почтовую программу, указанную в поле «Почтовая программа» вкладки «Общие» диалогового окна «Настройки G&I Mail Checker».

Список специальных уведомлений работает по принципу «редактирования на месте». Для того, чтобы включить редактирование на месте, необходимо вторично щелкнуть мышкой на уже отмеченном правиле, или нажать на клавиатуре <F2>. Вы можете отбирать письма либо по отправителю, либо по теме, при этом если отправитель должен точно совпадать с указанным значением, то тема проверяется на вхождение указанного текста без учета регистра. Так, если в графе «Содержит» написано «важно», то подходящими будут считаться письма с темами «ОЧЕНЬ ВАЖНО!», «Суперважно» и «Я неважно себя чувствую». В колонке «Реакция» добавлены еще два типа реакции на сообщения:

«Удалять с сервера» - письмо удаляется с сервера без загрузки. Это очень удобно использовать для борьбы со спамом, однако, будьте осторожны, не ставьте подобную реакцию, если в графе «Поле» у Вас стоит «Тема» - письма удаляются без возможности восстановления! Информация обо всех успешно удаленных с сервера письмах заносится в виде информационных сообщений в окно «G&I Mail Checker: Ошибки».

«Реакция по умолчанию» - реакция осуществляется в соответствии установкой в выпадающем списке «Для всех остальных сообщений:».

При обнаружении нового письма программа начинает просматривать список сверху вниз до тех пор, пока не найдет правило, подходящее для данного письма. Если программа находит соответствующее правило, то она реагирует в соответствии с указанной реакцией, если же ни одно из правил не подходит для письма, то программа реагирует на него согласно реакции в списке «Для всех остальных сообщений:».

Порядок следования правил Вы можете поменять с помощью кнопок [image] и [image] на панели инструментов или с помощью клавиш <Alt-Вверх> и <Alt+Вниз>. Кроме того, вы можете просто «перетащить» мышкой правило на нужное место. Для добавления правила служит кнопка [image] на панели инструментов или клавиша <Insert>. Удалить правило можно с помощью кнопки [image] на панели инструментов или клавишей <Del>. Если Вы при редактировании правила внесли неправильные данные, нажмите <Esc> - изменения отменятся, но диалоговое окно не закроется.

Все письма, для которых не стоит реакция «Не реагировать на сообщение» считаются непрочитанными до тех пор, пока Вы не закроете (или свернете) окно со списком сообщений.

Кнопка «Настройка звука…» открывает диалоговое окно «Настройка звуковой схемы», которое позволяет настроить звуковые уведомления о различных событиях.


Диалоговое окно «Свойства учетной записи»

Это окно позволяет настроить свойства отдельной учетной записи - имя сервера, имя пользователя, пароль и т.п. Оно появляется на экране, если пользователь создает новую учетную запись или редактирует существующую.

Окно содержит три вкладки:

Вкладка «Подключение» - позволяет задать адрес сервера, а также прочие параметры соединения.

Вкладка «Временные интервалы» - позволяет настроить время проверки почты, время ожидания сервера и т.п.

Вкладка «Firewall» - позволяет настроить проверку почты через Firewall. В текущей версии программы работа через Firewall не поддерживается.


Вкладка «Подключение» диалогового окна «Свойства учетной записи»

В этой вкладке Вы можете задать основные параметры установки соединения.

Окно редактирования «Название:» служит для указания имени учетной записи. Каждая ученая запись должна иметь уникальное имя, которое, однако, имеет чисто информационное значение и никаким образом не используется при установке соединения.

Окно редактирования «Сервер:» служит для указания имени почтового сервера.

Окно редактирования «Протокол:» служит для указания используемого протокола получения почты. В текущей версии программы поддерживается только протокол POP3.

Окно редактирования «Порт:» служит для указания порта почтового сервера для выбранного протокола. Для протокола POP3 обычно используется порт 110.

Окна редактирования «Имя пользователя:» и «Пароль:» служат для указания имени пользователя и его пароля для входа на почтовый сервер.

Если установлен флажок «Запрашивать пароль, если не удается провести авторизацию», то при получении отказа в авторизации от сервера Mail Checker запросит имя пользователя и пароль, и попытается повторить авторизацию. Однако стоит заметить, что отказ в авторизации не обязательно обусловлен ошибкой в пароле - например, сервер может быть перегружен.

Если установлен флажок «Выводить сообщение об ошибке в случае невозможности установки соединения или ошибки работы с сервером», то при возникновении каких-либо ошибок при установке соединения с сервером на экран будет выведено окно «G&I Mail Checker: Ошибки» со списком ошибок, произошедших во время работы. Если же этот флажок не установлен, окно не появится на экране, однако ошибка будет все равно зарегистрирована.


Вкладка «Временные интервалы» диалогового окна «Свойства учетной записи»

В этой вкладке Вы можете задать временные характеристики проверки почты для конкретной учетной записи. Все временные интервалы задаются индивидуально для каждой учетной записи.

Бегунок «Время ожидания сервера:» позволяет задать время, в течении которого Mail Checker будет ожидать ответа от сервера. Для соединений по телефонной линии это время рекомендуется задавать не меньше минуты. Однако, не задавайте этот период слишком большим - если в течение длительного времени от сервера не поступает ответа, это скорее всего означает ошибку связи. Для постоянного соединения это время зависит от качества соединения и загруженности сервера, и может быть существенно меньше.

Бегунок «Частота проверки почты:» позволяет задать периодичность проверки почты. Чем чаще Mail Checker будет проверять почту, тем быстрее он среагирует на поступившее сообщение, однако не ставьте частоту проверки слишком большой во избежание перегрузки сервера.

Флажок «Проверять почту в периоды:» позволяет задать специальные периоды проверки почты (например, только в рабочее время). Для задания таких периодов установите этот флажок и затем нажмите кнопу «Настроить…» справа от флажка. В открывшемся окне «Когда проверять почту» установите один или несколько периодов времени, когда необходимо производить проверку почты (например, ежедневно с 9:00 до 19:00).

Флажок «Не проверять почту в периоды:» позволяет задать периоды времени, в которые почта не будет проверяться (например, по выходным дням). Для задания таких периодов установите этот флажок и затем нажмите кнопу «Настроить…» справа от флажка. В открывшемся окне «Когда НЕ проверять почту» установите один или несколько периодов времени, в которые почту поверять не нужно (например, еженедельно с 19:00 пятницы по 9:00 понедельника).


Вкладка «Firewall» диалогового окна «Свойства учетной записи»

В текущей версии программы работа через Firewall не поддерживается.


Диалоговое окно «Добавление (редактирование) периода времени»

Это окно позволяет редактировать период времени. Mail Checker поддерживает три типа периодов времени:

«Ежедневно» - задает ежедневно повторяющийся интервал времени. Если время начала интервала больше времени конца, то подразумевается, что интервал заканчивается на следующие сутки. Это же правило относится и к другим типам интервалов.

«Еженедельно» - задает еженедельно повторяющийся интервал времени.

«Ежемесячно» - задает ежемесячно повторяющийся интервал времени.


Диалоговое окно «Когда проверять почту» («Когда НЕ проверять почту»)

Это окно позволяет редактировать список временных интервалов, которые определяют периоды времени, в которые надо (или не надо) проверять почту. Использование интервалов описано в справке по вкладке «Временные интервалы» диалогового окна «Свойства учетной записи». В этом окне Вы можете выполнить следующие операции со списком интервалов:

Добавить новый период времени (клавиша <Insert> на клавиатуре или кнопка [image] на панели инструментов). При этом откроется окно добавления нового периода времени.

Удалить период времени (клавиша <Delete> на клавиатуре или кнопка [image] на панели инструментов). Внимание! Mail Checker на спрашивает подтверждения перед удалением периода времени.

Редактировать период времени (клавиша <Enter> на клавиатуре, кнопка [image] на панели инструментов или двойной щелчок мыши по периоду времени в списке). При этом откроется окно редактирования периода времени.

Все изменения, которые вносятся в список временных интервалов, не будут запомнены до тех пор, пока Вы не нажмете на кнопку «Ok». Таким образом, если Вы случайно внесли неверные изменения (например, удалили период времени), то Вам достаточно нажать кнопку «Отмена» (или <Esc> на клавиатуре), и изменения будут отменены.


Диалоговое окно «Настройка звуковой схемы»

Это окно позволяет задать звуковую схему работы Mail Checker, т.е. указать, какие звуки будут проигрываться при наступлении различных событий. Кроме обычных устройств воспроизведения звука, Mail Checker может использовать встроенный динамик персонального компьютера (PC Speaker), что бывает удобно при отсутствии звуковой карточки или в тех случаях, когда ее использование невозможно (например, при выключенном звуке).

Список «События:» содержит перечень событий, которые могут наступить во время работы Mail Checker и соответствующие им звуки. В текущей версии имеются следующие события:

«Мигание значка» - Mail Checker обнаружил новую почту, для которой не задано никакой специальной реакции, но тем не менее на сообщение следует реагировать (см. Вкладка «Уведомления» диалогового окна «Настройки G&I Mail Checker»).

«Всплывающее окно» - Mail Checker обнаружил новую почту, для которой необходимо вывести всплывающее окно.

«Окно с сообщениями» - Mail Checker обнаружил новую почту, для которой необходимо вывести окно с сообщениями. Если окно с сообщениями выводится на экран по команде контекстного меню, то звукового оповещения не происходит.

«Запуск почтовой программы» - Mail Checker обнаружил новую почту, для которой необходимо запустить почтовую программу. Подача звукового сигнала происходит даже в том случае, если программе не удалось запустить почтовую программу, или почтовая программа не указана.

«Ошибки при проверке почты» - При проверке почты произошли ошибки, и в свойствах учетной записи, при работе с которой произошли ошибки, стоит флажок «Выводить сообщение об ошибке в случае невозможности установки соединения или ошибки работы с сервером». Если окно с сообщениями об ошибках выводится на экран по команде из контекстного меню, то звукового оповещения не происходит.

Ниже списка событий расположен переключатель типа звукового сообщения, допускающий следующие варианты:

«Нет звука» - на выбранное событие не предусмотрено звукового оповещения.

«Использовать PC Speaker» - звуковое оповещение для выбранного события будет воспроизводится с помощью внутреннего динамика персонального компьютера. При этом в выпадающем списке «Мелодия:» Вы можете указать мелодию, которая будет воспроизводиться. Подробнее об использовании мелодий см. ответ на вопрос «Как задать свои собственные мелодии для звукового оповещения?».

«Использовать MIDI-устройство» - звуковое оповещение для выбранного события будет воспроизводится с помощью устройства MIDI, используемого в системе как основное (обычно MIDI Mapper). Если в системе нет MIDI-устройства, то этот пункт будет запрещен. В поле редактирования «Файл:» необходимо указать файл в формате MIDI (*.mid, *.rmi), который следует использовать. Файл можно выбрать с помощью кнопки «…», расположенной справа от поля редактирования.

«Использовать WAVE-устройство» - звуковое оповещение для выбранного события будет воспроизводится с помощью устройства волнового синтеза (Wave), используемого в системе как основное. Если в системе нет ни одного WAVE-устройства, то этот пункт будет запрещен. В поле редактирования «Файл:» необходимо указать файл в формате WAV или MP3, который следует использовать. Файл можно выбрать с помощью кнопки «…», расположенной справа от поля редактирования. Поскольку Mail Checker не содержит собственного декодера MP3, воспроизведение возможно только в том случае, если в системе установлен соответствующий декодер.

В принципе, использование различных устройств для воспроизведения должно обеспечивать независимость воспроизведения звуков на различных устройствах, однако, например, при использования системы SoundFont для Sound Blaster, при синтезе MIDI устройство волнового синтеза оказывается занятым, и Mail Checker не сможет воспроизвести звук на WAVE-устройстве. Также не будет подано звукового оповещения, если звуковое устройство (кроме PC Speaker) занято другой программой.

Проверить звучание Вы можете с помощью кнопки [image]. Кнопка [image] останавливает все звуки, которые Mail Checker в данный момент воспроизводит.

Флажок «Выключать звук при обращении к меню» служит для выключения всех звуков при обращении к контекстному меню Mail Checker. Однако это не значит, что Mail Checker больше не будет воспроизводить звуки - как только произойдет событие, для которого необходимо воспроизвести звук, звук вновь будет воспроизведен. Если этот флажок не установлен, в контекстном меню появляется пункт «Выключить звук!».

Поле редактирования «Длительность звучания в «тихом» режиме, не более:» служит для указания максимального времени звучания любого звука, когда программа находится в т.н. «тихом» режиме.


Диалоговое окно «Ошибка авторизации»

Это окно появляется в том случае, если при проверке почты не удается получить авторизацию на сервере, и только тогда, когда установлен соответствующий флажок для ученой записи (см. вкладку «Подключение» окна «Свойства учетной записи»). Это может быть вызвано как тем, что был неверно указан пароль или имя пользователя, так и другими причинами, например, перегрузкой сервера. Для того, чтобы определить причину невозможности авторизации, следует внимательно прочитать ответ сервера (который, к сожалению, обычно бывает на английском языке).

Если действительно неверно указан пароль или имя пользователя, то Вам предоставляется возможность указать их в соответствующих окнах и попробовать вторично произвести авторизацию, нажав кнопку «Ok». Mail Checker тут же произведет попытку проверки почты, и если окно не появиться снова в течение небольшого промежутка времени, значит, Вы верно указали пароль. Mail Checker запомнит его и будет использовать его в дальнейшеем.

Если же причина заключается в перегруженности сервера (или, например, сервер не допускает проверку почты одним и тем же пользователем в течении определенного промежутка времени), то нажмите кнопку «Отмена» для того, чтобы прервать проверку и установите более длительный интервал проверки почты (см. вкладку «Временные интервалы» окна «Свойства учетной записи»).


Диалоговое окно «Завершение работы G&I Mail Checker»

Это окно появляется при выборе пункта меню «Завершение работы» из основного меню программы, в том случае, если установлен соответствующий флажок.

В принципе, реально редко возникает необходимость вручную завершать работу программы, так как Mail Checker практически не занимает ресурсов компьютера. Если у Вас постоянное подключение, то, если Вы не хотите, чтобы Mail Checker проверял почту, просто приостановите проверку с помощью команды основного меню «Приостановить». Если же у вас Dialup-соединение (по телефонной линии), то Вы можете так настроить Mail Checker, что он будет автоматически запускаться при установке соединения и выгружаться при завершении.

Подробнее об это см. в комментариях ко вкладке «Общие» диалогового окна «Настройки G&I Mail Checker».


Диалоговое окно «G&I Mail Checker: Повторный запуск»

Это окно появляется при при попытке запуска второй копии Mail Checker.

Mail Checker запускает только в единственно экземпляре, во избежание конфиликтов между копиями, да и за ненадобностью. При запуске на панели задач появляется иконка Mail Checker, щелкнув по которой правой кнопкой мышки Вы вызовете основное меню программы, с помощью которого осуществляется доступ к всем функциям.

Если Вы хотите предотвратить появление этого окна на экране (например, при использовании автоматического запуска), укажите ключ /AUTOSTART в командной строке. Пи запуске с этим ключом окно с предупреждением не появляется, однако запущенный экземпляр Mail Checker инициирует проверку почты для всех учетных записей, для которых проверка в данный момент допустима по временным интервалам (см. вкладку «Временные интервалы» окна «Свойства ученой записи»).

Если Вы нажмете кнопку «Настройки...» то откроется диалоговое окно «Настройки G&I Mail Checker».


Окно «G&I Mail Checker - Список писем»

Это окно появляется на экране при двойном щелчке на значок в панели задач, выборе пункта «Письма...» основного меню, либо появляется автоматически при поступлении новой почты, если это указано в правилах уведомления.

Окно содержит меню, панель инструментов, строку статуса и собственно список писем. В этом окне Вы можете просмотреть информацию о поступивших письмах, заголовок письма, а также удалить письма, не загружая их с сервера.

Заголовок списка писем позволяет изменить порядок сортировки писем, для чего достаточно просто щелкнуть мышкой по заголовку соответствующего столбца. При этом текущий столбец сортировки отмечается значком [image] или [image] в зависимости от порядка сортировки. Чтобы изменить порядок сортировки, достаточно второй раз щелкнуть по тому же заголовку окна.

Кроме того, Вы можете настроить ширину колонок и их последовательность с помощью мышки. При этом ширина и расположение колонок, а также порядок сортировки сохранятся в реестре.

Если какое-либо из полей письма не отображается в списке, или отображается в неверной кодировке, значит, Mail Checker не смог корректно разобрать заголовок письма. Обычно это бывает в случаях получения т.н. спама, т.е. писем с разным мусором, или рекламных рассылок. Вы можете уточнить информацию, дважды щелкнув левой кнопкой мышки по соответствующему письму, при этом откроется окно «Заголовок письма», в котором заголовок письма будет показан в том виде, в каком он был получен с сервера.

Кроме того, рекомендуем обращать внимание на размер письма, т.к. размер обычного письма редко бывает больше 50Кб, письма большего размера, если Вы их не ожидаете, должны вызывать по меньшей мере настороженность. Подробнее см. «Как бороться со спамом».

Кроме того, с помощью меню этого окна Вы можете быстро создать правило уведомления для какого-либо письма.


Почему Mail Checker выгружается практически сразу после запуска?

Внимательно прочтите эту информацию, прежде чем установить флажок «Выгружать программу при отсутствии Dialup-соединения»!

Проверка наличия Dialup-соединения Mail Checker производит, когда наступает время очередной проверки почты. В случае, если Mail Checker не обнаруживает ни одного активного Dialup-соединения, и флажок «Выгружать программу при отсутствии Dialup-соединения» (см. Вкладку «Общие» диалогового окна «Настройки G&I Mail Checker») установлен, то он автоматически завершает работу. Учитывая то, что первая проверка почты осуществляется приблизительно через 1 сек. после запуска, то при отсутствии соединения Mail Checker практически сразу выгрузится из памяти.

Для решения этой проблемы предусмотрен параметр командной строки /PAUSE, который позволяет запустить Mail Checker в приостановленном режиме, в котором вы сможете спокойно внести любые изменения в установки (в том числе и снять флажок «Выгружать программу при отсутствии Dialup-соединения»).

Этот флажок удобно использовать в комбинации с подключением к списку запуска ICQ NetDetect Agent, после того, как все остальные настройки будут выполнены. Таким образом, Mail Checker будет загружаться вместе с установлением Dialup-соединения, и выгружаться автоматически спустя некоторое время после потери соединения.

Для пользователей, использующих постоянное IP-соединение, данная опция не только бессмысленна, но и вредна - при ее установке Mail Checker все время будет выгружаться, так как не сможет найти ни одного Dialup-соединения, а так как данная опция работает только с установленным флажком «Производить проверку только при установленном Dialup-соединении», то проверка почты вообще производится не будет!

Для дополнительной информации см. ответ на вопрос «Все настроено верно, а почта не проверяется! Почему?»

P.S. Это не баг, это фича!


Все настроено верно, а почта не проверяется! Почему?

Если Mail Checker просто не проверяет почту, не выдавая никаких сообщений об ошибках, то, скорее всего, это происходит из-за того, что в настройках программы (панель «Общие») установлен флажок «Производить проверку только при установленном Dialup-соединении», а компьютер подключен по постоянному IP-соединению. Вышеуказанный флажок обеспечивает проверку только при подключении по Dialup-соединению (RAS connection), и, таким образом, при постоянном соединении Mail Checker считает, что соединение отсутствует, и не производит проверку почты. Снимите этот флажок в окне «Настройки G&I Mail Checker», вкладка «Общие».


Как задать свои собственные мелодии для звукового оповещения?

Мелодии, которые Mail Checker проигрывает на PC Speaker, описаны в файле GIMCheck.MUS. расположенном в том же каталоге, что и основной исполняемый файл GIMCheck.EXE (обычно в каталоге C:\Program Files\Gekus & Igori Mail Checker). Файл имеет обычный текстовый формат и может редактироваться с помощью любой программы редактирования текста, например, Notepad (Блокнот), входящий в комплект Windows.

Этот файл имеет следующий формат:

Символ «;» (точка с запятой) обозначает комментарий, т.е все символы в строке, находящиеся после точки с запятой, игнорируются.

Каждая мелодия хранится в отельной секции, заголовок которой представляет собой название мелодии, заключенное в квадратные скобки. Это название и будет в дальнейшем показываться в выпадающем списке в окне «Настройка звуковой схемы».

Следующие за заголовком строки задают мелодию. Ниже приведена таблица символов, используемых при описании.

C,D.E.F,G,A,H[+|-|#][<число>] | Проиграть ноту. Буквы соответствуют принятым в музыкальной грамоте буквенным обозначениям нот, т.е. C - До, D - Ре и т.д. Знак + или # повышает ноту на полтона, знак - понижает на полтона. Число, следующее за нотой, обозначает ее музыкальную длительность. Например, D-16 обозначает ноту Ре-бемоль шестнадцатой длительности. Если длительность отсутствует, используется длительность по умолчанию. К сожалению, в текущей версии Mail Checker триоли не поддерживаются.
B | Соответствует H- (Си-бемоль).
P[<число>] | Пауза. Число задает длительность паузы, так же, как и для ноты.
T[<число>] | Задает темп воспроизведения мелодии. Число указывает количество четвертых нот в минуту. Если темп не указан, используется темп 120 четвертей в минуту. Допустимый диапазон темпов от 20 до 400 четвертей.
O[<число>] | Задает октаву. Диапазон допустимых значений от 1 до 8, при этом 4 соответствует первой октаве. Если октава на указана, используется первая октава.
I[<число>] | Задает длительность нот по умолчанию. Если длительность по умолчанию не указана, то используются четвертные ноты.

Пример:

Всеми любимый «Чижик-пыжик» будет выглядеть примерно так:

[Chizhick-Pyzhick]

T340O4AFAFBAG2CCCD8E8FFFP

В дальнейшем планируется реализовать поддержку триолей, режимов стаккато и легато, указания длительности нот в миллисекундах, а также возможность конвертирования трека из MIDI-файла. Следите за обновлениями!

Если Вам удалось придумать красивую или просто прикольную мелодию, или если Вы хотите использовать библиотеку проигрывания мелодии на PC Speaker - пишите.


................................................................
. Видимо, в качастве коментария в этом тексте можно
. использовать точку в начале строки
................................................................
.
................................................................
. Кнопки общего нзначения (Ok, Cnacel и т.п.)
................................................................
.topic 1
Закрытие диалогового окна с сохранением всех измененных значений параметров.
.topic 2
Закрытие диалогового окна без сохранения изменений в значениях параметров.
.topic 3
Отменить выполнение запрошенной операции.
.topic 4
Попытаться повторить выполнение запрошенной операции.
.topic 5
Игнорировать возникшую ошибку и продолжить выполнение.
Внимание! Не рекомендуется игнорировать ошибки, возникающие в процессе работы. Лучше разобраться в причинах ошибки и повторить операцию.
.topic 6
Подтвердить выполнение операции.
.topic 7
Отменить выполнение операции.
.topic 8
Закрыть диалоговое окно без сохранения изменений в значениях параметров (подразумевается, что все изменения, сделанные в окне, уже сохранены, например, с помощью кнопки "Применить").
.topic 9
Вывести раздел справки, соответствующий данному диалоговому окну.
.
................................................................
. Иконки, в которые тыкают идиоты
................................................................
.topic 1090
Ну и зачем сюда тыркать? Иконка, она иконка и есть!
.topic 1091
Ну и зачем сюда тыркать? Иконка, она иконка и есть!
.topic 1004
Ну и зачем сюда тыркать? Иконка, она иконка и есть!
.topic 1056
Ну и зачем сюда тыркать? Иконка, она иконка и есть!
.topic 1075
Ну и зачем сюда тыркать? Ну, картиночка нарисована!
.
................................................................
. Элементы вкладки "Общие" окна "Настройки"
................................................................
.topic 1077
В этом окне указывается имя исполняемого файла почтовой программы, которую следует запускать. Если оставить это окно пустым, почтовая программа запускаться не будет.
.topic 1078
Открыть окно выбора файла, для того, чтобы указать исполняемый файл почтовой программы.
.topic 1079
Если этот флажок установлен, то Mail Checker не будет производить проверку почты при отсутствии Dialup-соединения. Если Вы подключены к Internet по постоянному IP-соединению, не устанавливайте этот флажок.
.topic 1080
Установите этот флажок для того, чтобы прописать строку запуска Mail Checker в ICQ Lunch List. В этом случае, когда ICQ NetDetect Agent обнаружит наличие подключения к Internet, Mail Checker запустится автоматически.
.topic 1081
Если этот флажок установлен, то Mail Checker не будет выполнять проверку почты, если запущена почтовая программа. Это необходимо для того, чтобы избежать конфликтов при попытке одновременной проверки почты почтовой программой и Mail Checker. Если имя исполняемого файла почтовой программы не указано, этот флажок н действует.
.topic 1082
Если этот флажок установлен, то Mail Checker автоматически завершит работу, если при очередной попытке проверки почты ему не удастся обнаружить Dialup-соединение. Более подробная информация содержится в ответе на вопрос "Почему Mail Checker выгружается практически сразу после запуска?"
.topic 1083
Если этот флажок установлен, Mail Checker будет запрашивать подтверждение завершения работы.
.topic 1087
Время, в течении которого Mail Checker хранит сообщения об ошибках, возникшие в результате проверки почты. Если значение установлено в 0, то старые сообщения об ошибках удаляются перед началом новой проверки.
.topic 1088
Время, в течении которого Mail Checker хранит сообщения об ошибках, возникшие в результате проверки почты. Если значение установлено в 0, то старые сообщения об ошибках удаляются перед началом новой проверки.
.topic 1097
Выберите язык, на котором Вы хотите видеть диалоги, меню и другие элементы пользовательското интерфейса,
а также подсказку (если соответствующий файл имеется в наличии).
.
................................................................
. Элементы вкладки "Учетные записи" окна "Настройки"
................................................................
.topic 1002
Список учетных записей. Для выполнения операции с ученой записью нажмите кнопку на панели инструментов или щелкните правой кнопкой мышки по ученой записи для получения контекстного меню.
.topic 1003
Панель инструментов для работы с учеными записями. Нажмите кнопку в правой части панели для выполнения операции.
.topic 32775
Удалить ученую запись. Перед удалением программа запросит подтверждение выполнения операции.
.topic 32777
Добавить новую ученую запись. Откроется диалоговое окно "Новая учетная запись".
.topic 32778
Редактировать отмеченную учетную запись. Откроется диалоговое окно "Свойства учетной записи".
.
................................................................
. Кнопки вкладки "Уведомления" окна "Настройки"
................................................................
.topic 1051
Список специальных уведомлений. Для работы со списком нажмите кнопку на панели инструментов или щелкните правой кнопкой мышки на строке списка. Для активизации редактирования на месте используйте кнопку F2.
.topic 1050
Панель инструментов для работы со списком специальных уведомлений. Нажмите кнопку в правой части панели для выполнения операции.
.topic 1052
Реакция на сообщения (письма), не попадающие не под одно из условий специального уведомления, перечисленных в списке выше.
.topic 1053
Настройка звуковых уведомлений о наступлении различных событий.
.topic 32783
Переместить правило специального уведомления на одну позицию вверх.
.topic 32784
Переместить правило специального уведомления на одну позицию вниз.
.topic 32786
Добавить новое правило специального уведомления.
.topic 32787
Удалить отмеченное правило специального уведомления.
.
................................................................
. Кнопки вкладки "Подключение" окна "Свойства учетной записи"
................................................................
.topic 1009
В этом окне указывается имя ученой записи. Имя ученой записи используется для идентификации ученой записи и должно быть уникальным.
.topic 1005
В этом окне указывается адрес сервера входящей почты.
.topic 1010
В этом списке указывается используемый протокол получения почты. Текущая версия программы поддерживает только протокол POP3.
.topic 1007
В этом окне указывается номер порта сервера входящей почты. Для протокола POP3 это обычно порт 110.
.topic 1011
В этом окне указывается номер порта сервера входящей почты. Для протокола POP3 это обычно порт 110.
.topic 1012
В этом окне указывается имя пользователя почтового сервера.
.topic 1013
В этом окне указывается пароль пользователя почтового сервера.
.topic 1018
Если этот флажок установлен, то при возникновении ошибок во время проверки почты окно с сообщениями об ошибках будет сразу выведено на экран.
.topic 1021
Если это флажок установлен, то Mail Checker запросит пароль, если при попытке установки соединения произойдет ошибка авторизации.
.
................................................................
. Кнопки вкладки "Временные интервалы" окна "Свойства учетной записи"
................................................................
.topic 1015
Этот бегунок позволяет задать время ожидания ответа сервера. Для соединения по телефонной линии рекомендуемое время 1 минута, для постоянного соединения это время может быть и меньше.
.topic 1022
Время ожидания ответа сервера.
.topic 1016
Этот бегунок позволяет задать частоту проверки почты. Во избежание перегрузки сервера не устанавливайте большую частоту проверки.
.topic 1023
Частоту проверки почты.
.topic 1014
Установите этот флажок, если Вы хотите задать специальные периоды проверки почты для данной учетной записи. Для указания этих периодов нажмите кнопку "Настроить…" справа от флажка.
.topic 1017
Нажмите на эту кнопку, чтобы настроить интервалы времени, в которые Mail Checker будет проверять почту.
.topic 1024
В этом окне показаны временные интервалы, в которые Mail Checker будет проверять почту. Для их изменения нажмите кнопку "Настроить…" справа от флажка "Проверять почту в периоды:"
.topic 1019
Установите этот флажок, если Вы хотите задать специальные периоды времени, когда нужно приостановить проверку почты для данной учетной записи (например, ночью или в выходные дни). Для указания этих периодов нажмите кнопку "Настроить…" справа от флажка.
.topic 1020
Нажмите на эту кнопку, чтобы настроить интервалы времени, в которые Mail Checker не будет проверять почту.
.topic 1025
В этом окне показаны временные интервалы, в которые Mail Checker не будет проверять почту. Для их изменения нажмите кнопку "Настроить…" справа от флажка "Не проверять почту в периоды:"
.
................................................................
. Кнопки окна "Когда проверять почту"
................................................................
.topic 1040
Список периодов времени. Для выполнения операции с периодом времени нажмите кнопку на панели инструментов или щелкните правой кнопкой мышки по периоду времени для получения контекстного меню.
.topic 1026
Панель инструментов для работы с периодами времени. Нажмите кнопку в правой части панели для выполнения операции.
.topic 32779
Редактировать период времени. Откроется диалоговое окно "Редактирование периода времени"
.topic 32780
Добавить новый период времени. Откроется диалоговое окно "Добавление периода времени".
.topic 32781
Удалить отмеченный период времени.
Внимание! Перед удалением Mail Checker не запрашивает подтверждения!
.
................................................................
. Кнопки окна "Период времени"
................................................................
.topic 1027
Установите этот переключатель для ежедневно повторяющегося интервала времени.
.topic 1028
Установите этот переключатель для еженедельно повторяющегося интервала времени.
.topic 1029
Установите этот переключатель для ежемесячно повторяющегося интервала времени.
.topic 1043
Время, с которого начинается ежедневный период времени.
.topic 1030
Время, с которого начинается ежедневный период времени.
.topic 1044
Время, которым заканчивается ежедневный период времени.
.topic 1031
Время, которым заканчивается ежедневный период времени.
.topic 1032
Время, с которого начинается еженедельный период времени.
.topic 1033
Время, которым заканчивается еженедельный период времени.
.topic 1045
День недели, с которого начинается еженедельный период времени.
.topic 1034
День недели, с которого начинается еженедельный период времени.
.topic 1046
День недели, которым заканчивается еженедельный период времени.
.topic 1035
День недели, которым заканчивается еженедельный период времени.
.topic 1036
Время, с которого начинается ежемесячный период времени.
.topic 1037
Время, которым заканчивается ежемесячный период времени.
.topic 1047
День месяца, с которого начинается ежемесячный период времени.
.topic 1038
День месяца, с которого начинается ежемесячный период времени.
.topic 1039
День месяца, с которого начинается ежемесячный период времени.
.topic 1048
День месяца, которым заканчивается ежемесячный период времени.
.topic 1041
День месяца, которым заканчивается ежемесячный период времени.
.topic 1042
День месяца, которым заканчивается ежемесячный период времени.
.
................................................................
. Кнопки окна "Звуковая схема"
................................................................
.topic 1058
Список доступных для озвучания события
.topic 1059
Если установлен этот переключатель, звук не будет воспроизводися
.topic 1060
Если установлен этот переключатель, будет проиграна выбранная мелодия на PC Speaker
.topic 1061
Если установлен этот переключатель, будет воспроизведен файл на устройстве MIDI Mapper
.topic 1062
Если установлен этот переключатель, будет воспроизведен файл на волнового синтеза
.topic 1069
Эта кнопка воспроизводит выбранный звук
.topic 1068
Эта кнопка останавливает все звуки, воспроизводимые в данный момент.
.topic 1063
Выберите мелодию, которую Вы хотите воспроизвести на PC Speaker.
Если Вы хотите узнать, как создавать собственные мелодии, нажмите кнопку "Справка"
.topic 1070
Выберите мелодию, которую Вы хотите воспроизвести на PC Speaker.
.topic 1072
Выберите файл для воспроизведения на устройстве волнового синтеза.
.topic 1066
Выберите файл для воспроизведения на устройстве волнового синтеза.
.topic 1067
Нажмите эту кнопку для выбора файла из списка.
.topic 1071
Выберите файл для воспроизведения на MIDI-устройстве.
.topic 1064
Выберите файл для воспроизведения на MIDI-устройстве.
.topic 1065
Нажмите эту кнопку для выбора файла из списка.
.topic 1085
Продолжительность звучания любого звука в тихом режиме.
.topic 1086
Продолжительность звучания любого звука в тихом режиме.
.topic 1084
Если этот флажок установлен, при обращении к основному меню программы все воспроизводимые звуки выключаются.
.
................................................................
. Кнопки окна "Ошибки авторизации"
................................................................
.topic 1076
Подробна информация об ошибке авторизации, в том числе и ответ сервера
.topic 1073
Имя пользователя для повторной попытки авторизации
.topic 1074
Пароль пользователя для повторной попытки авторизации
.
................................................................
. Кнопки окна "About"
................................................................
.topic 1006
Нажмите сюда, чтобы отправить письмо Заливочкину Евгению Владимировичу
.topic 1008
Нажмите сюда, чтобы отправить письмо Овчаренко Игорю Викторовичу
.
................................................................
. Кнопки окна "Double start"
................................................................
.topic 1001
Нажмите на эту кнопку, чтобы открыть окно настроек Mail Checker
.
................................................................
. Кнопки окна "Message Header"
................................................................
.topic 1054
Текст заголовка письма, полученный с сервера. Для изменения кодировки и шрифта щелкните правой кнопкой
мышки по тексту сообщения
.
................................................................
. Кнопки окна "Error list"
................................................................
.topic 1055
Список ошибок, произошедших во время послежних проверок почты. Время хранения информации об ошибках задается
во вкладке "Общие" окна "Настройки Mail Checker"
.topic 1057
Общая информация о результатах последней проверки


Команда «О программе...»

Меню: | Меню окна со списком писем, подменю «?», Основное меню программы.
Панель инструментов: | (окно со списком писем)

По этой команде открывается окно «О программе G&I Mail Checker», в котором Вы можете прочитать информацию о версии программы, а также об ее авторах.


Команда «Приостановить/Возобновить»

Меню:

Основное меню программы

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Команда контекстной справки по объекту

Клавиатура: | <Shift>+<F1>
Панель инструментов: | (окно со списком писем)

По этой команде курсор мышки изменяется на [image], и Вы можете выбрать объект, по которому Вы хотите получить справку.


Команда «Создать правило по отправителю...»

Меню:

Меню окна со списком писем, подменю «Правка», Контекстное меню списка писем

По этой команде Mail Checker автоматически откроет вкладку «Уведомления» диалогового окна «Настройки G&I Mail Checker» и создает правило, указывая в условия отправителя данного письма. Вы можете выбрать необходимую реакцию на письмо от данного отправителя. Для создания адреса используется E-Mail-адрес, указанный отправителем, а не его мнемоническое имя.


Команда «Создать правило по теме...»

Меню:

Меню окна со списком писем, подменю «Правка», Контекстное меню списка писем

По этой команде Mail Checker автоматически откроет вкладку «Уведомления» диалогового окна «Настройки G&I Mail Checker» и создает правило, указывая в условие тему отмеченного письма. Вы можете выбрать необходимую реакцию на письмо от данного отправителя. Прежде, чем создавать правило уведомления по теме письма, внимательно прочтите справку к этой вкладке.


Команда «Ошибки...»

Меню:

Основное меню программы

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Команда «Письма...»

Меню: | Основное меню программы
Мышь: | Двойной щелчок по значку программы на панели задач

По этой команде открывается окно «G&I Mail Checker - Список писем», в котором показываются все письма, обнаруженные на данный момент. В этом окне Вы можете просмотреть информацию о письме, заголовок письма, а также удалить ненужные письма, не скачивая их с сервера.


Команда «Настройки...»

Меню:

Основное меню программы

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Команда «Содержание»

Меню: | Меню окна со списком писем, подменю «?», Основное меню программы.
Клавиатура: | <F1>

По этой команде открывается окно с содержание справки.


Команда «Проверить сейчас \ <Учентная запись>»

Меню:

Основное меню программы.

По это команде инициируется проверка почты для всех учетных записей, кроме тех, для которых проверка почты выполняется в настоящий момент.


Команда «Проверить сейчас (все учетные записи)»

Меню: | Меню окна со списком писем, подменю «Файл», Основное меню программы.
Панель инструментов: | (окно со списком писем)

По это команде инициируется проверка почты для всех учетных записей, кроме тех, для которых проверка почты выполняется в настоящий момент.


Команда «Закрыть окно»

Меню: | Меню окна со списком писем, подменю «Файл»
Панель инструментов: | (справа в заголовке окна)

По этой команде окно со списком писем закрывается, и все письма помечаются как просмотренные, т.е. при следующем сеансе проверки почты Mail Checker уже не будет на них реагировать.


Команда «Удалить отмеченные»

Меню: | Меню окна со списком писем, подменю «Правка», Контекстное меню списка писем
Панель инструментов: | (окно со списком писем)

По этой команде запускается сеанс проверки почты для тех учетных записей, с которых получены письма, помеченные для удаления. Подробнее см. команду «Пометить на удаление».


Команда «Пометить на удаление»

Меню: | Меню окна со списком писем, подменю «Правка», Контекстное меню списка писем
Клавиатура: | <Del>
Панель инструментов: | (окно со списком писем)

По этой команде выбранное письмо помечается для последующего удаления. Это бывает удобно для писем, которые Вы по тем или иным причинам не хотите получать (например, спам, рекламные рассылки и т.п.). Письмо удаляется с сервера без загрузки на локальный компьютер, что, во-первых, экономит время связи, а, во-вторых, позволяет удалить подозрительные письма даже не скачивая их на свой компьютер. Отмеченной на удаление письмо помечается перечеркнутой крест-накрест иконкой справа от письма.

Письма, отмеченные для удаления, удаляются не сразу, а только при очередном сеансе проверки почты, инициированном как вручную, так и автоматически. При этом Вы можете запустить сеансы проверки почты только для тех учетных записей, письма которых Вы отметили для удаления, с помощью команды «Удалить отмеченные» (в отличие от команды «Проверить сейчас (все учетные записи)», когда проверка запускает для всех учетных записей.

Если Вы случайно отметили для удаления письмо, которое удалять не нужно, просто выберите еще раз эту команду, и отметка будет снята.

Информацию обо всех удаленных письмах, как явно помеченных для удаления, так удаленных согласно правилам уведомления, Вы можете увидеть в окне «G&I Mail Checker: Ошибки».


Команда «Заголовок...»

Меню: | Меню окна со списком писем, подменю «Правка», Контекстное меню списка писем
Клавиатура: | <Enter>
Панель инструментов: | (окно со списком писем)
Мышь: | Двойной щелчок по письму

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Команда «Запустить почтовую программу»

Меню: | Меню окна со списком писем, подменю «Файл»
Клавиатура: | <WinKey> + <P>
Панель инструментов: | (окно со списком писем)

По этой команде запускается почтовая программа, указанная во вкладке «Общие» диалогового окна «Настройки G&I Mail Checker». Если почтовая программа не указана, то этот пункт меню запрещен. При запуске почтовой программы из окна со списком писем это окно автоматически закрывается, и все письма помечаются как прочитанные.

Кроме того, при запущенном Mail Checker, Вы можете запустить почтовую программу в любой момент, нажав <WinKey>+<P>.


Команда «Завершить работу»

Меню:

Основное меню программы

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Команда «Удалить» (учетные записи)

Команда «Удалить»

Меню: | Контекстное меню списка писем
Клавиатура: | <Del>
Панель инструментов: | (вкладка «Учетные записи» диалогового окна «Настройки G&I Mail Checker»)

Эта команда удаляет учетную запись из списка учетных записей, предварительно запросив подтверждение выполнения операции.

Если Вы случайно удалили учетную запись, у Вас еще остается возможность не вносить изменения в список учетных записей. Достаточно нажать кнопку «Отмена», и все внесенные изменения будут отменены.


Команда «Добавить...» (учетные записи)

Команда «Добавить...»

Меню: | Контекстное меню списка писем
Клавиатура: | <Insert>
Панель инструментов: | (вкладка «Учетные записи» диалогового окна «Настройки G&I Mail Checker»)

По этой команде открывается диалоговое окно «Новая учетная запись», в котором Вы можете создать новую учетную запись.


Команда «Свойства...» (учетные записи)

Команда «Свойства...»

Меню: | Контекстное меню списка писем
Клавиатура: | <Enter>
Панель инструментов: | (вкладка «Учетные записи» диалогового окна «Настройки G&I Mail Checker»)
Мышь: | Двойной щелчок по учетной записи

По этой команде открывается диалоговое окно «Свойства учетной записи», в котором Вы можете внести изменения в параметры существующей учетной записи.


Команда «Напомнить позже»

Меню: | Меню окна со списком писем, подменю «Файл»
Панель инструментов: | (окно со списком писем)

По этой команде окно со списком писем закрывается, но письма не помечаются как прочитанные. Таким образом, при следующем сеансе проверке почты (инициированном вручную или автоматически) Mail Checker снова среагирует на них согласно настройкам во вкладке «Уведомления» диалогового окна «Настройки G&I Mail Checker», если, конечно, до этого времени письма не будут удалены с сервера.


Команда «"Тихий" режим»

Меню:

Основное меню программы

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Команда «Выключить звук!»

Меню: | Основное меню программы
Панель инструментов: | (окно со списком писем)

По этой команде открывается окно «Заголовок сообщения», в котором показывается заголовок письма в том виде, в котором он был получен с сервера. Это бывает удобно для получения дополнительной информации о письме, а также в тех случаях, когда Mail Checker не смог корректно разобрать поля в заголовке письма.

См. также: Разбор заголовков писем.


Панель инструментов окна «G&I Mail Checker - Список писем»

Панель инструментов служит для быстрого выполнения часто используемых команд и располагается обычно ниже строки меню в окне со списком писем, однако с помощью мыши Вы можете расположить панель инструментов в любом удобном для Вас месте. Расположение панели инструментов запоминается в реестре. Ниже на рисунке приведен пример панели инструментов.

Запустить почтовую программу

Выключить все воспроизводимые в данный момент звуки

Показать заголовок письма

Отметить сообщение для удаления

Удалить все отмеченные сообщения

Проверить почту для всех учетных записей

Напомнить позднее о непрочитанных письмах

Вывести информацию о версии и разработчиках

Показать справку по конкретному объекту